Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WidevineCdm error Netflix
I am looking for a fix for this. When I start a netflix movie I get this error message: 

We cannot find all the required components to play Netflix on this device. Please visit chrome://components, locate the WidevineCdm component, and click the "Check for update" button. For additional assistance resolving this issue.

When I go to chrome://components, WidevineCdm is not listed, it is not isted in chrome://plugins either.. I can get it to work with internet explorer and google chrome and other browsers.
I'm having the same error...
We knew this issue.Because chromium doesn't include WidevineCdm by default.
This will be fixed in the next version.Currently please use Chrome to visit Netflix.
I'm sorry for the inconvenience.
Ok, thank you for answering. will keep an eye out for next update
please, disable auto-playing HTML5 videos. I hate this
(08-04-2015, 05:37 PM)reactor Wrote: please, disable auto-playing HTML5 videos. I hate this

We will have a research on this issue.
Still having issues with WidevineCdm in 64-bit installer on new version (v1.3.19.45) on my PC
New version will be in few days.
In case people come here via Google like I did. I found a solution that worked. The issue was incorrect permissions on the widevinecdm folder. 

Another user (boomRoasted896) published this here (external link):
1.) Navigate to C:\Users\{user name}\AppData\Local\Google\Chrome\User Data
2.) right click on the "WidevineCDM" directory and go to the "Security" Tab.
3.) For me the only groups/users listed were system owner and Administrators.  Add the {local machine}\Users group to the security list, read & execute, List Folder Contents and Read should suffice.
4.) I received an error saying it was not able to replicate to children folders.
5.) I then drilled down into the path further to this C:\Users\{user name}\AppData\Local\Google\Chrome\User Data\WidevineCDM\\_platform_specific\win_x64 and ensured the the Users groups was added in the security tab for each directory.
6.) in the win_x64 tab you will see the widevinecdm.dll among others, make sure they all have the Users groups added to the security list.
7.) I had chrome open when I did, I needed to close it down and re-open before the fix worked.  Sometimes chrome continues to run in the background I have found, so you may need to open task manager to close it there.

This is the only solution that worked for me, and seems to have fixed the issue.
Thank you for your advice, dasarp.
But the issue is only presented in Chromium not Chrome, because Chromium doesn't include WidevineCDM package by default.
And it is fixed in our next release.

Forum Jump:

Users browsing this thread: 1 Guest(s)